This profile is from a federated server and may be incomplete. View on remote instance

Decision of Next Os

I was Nobara user, then I am using Fedora right now. I want to use things like Hyprland etc. and ya know, Its damn cool to say I am using arch btw. So I've decided to use Arch Linux. But everyone says its always breaking and gives problems. That's because of users, not OS.. right? I love to deal with problems but I don't want to...

Varen ,
@Varen@kbin.social avatar

Rolling release 🤷🏻‍♂️ there might be updates which cause issues where you might need to rollback, if you can handle that it shouldn‘t be a problem.

I‘m using Arch myself since about 2 months and never happened that an update break something for me - when something broke it was my own fault.

Varen ,
@Varen@kbin.social avatar

Nah, I run my updates maybe once a week on average. If afterwards something breaks, I simply do a complete Rollback (with e. g. snapshots). If after the next update its still broken, then I start to dig in „what“ is broken and how I might fix it

But as I said, it didn‘t happen to me yet - but I‘m also fairly new to Arch as well, so that‘s at least my plan on how I would go after it.

Varen , to Linux
@Varen@kbin.social avatar

got told to crosspost over here to reach more people:

https://kbin.social/m/linuxquestions/p/4631784

I don't know if and how crossposting functions in kbin/lemmy, so hopefully it'll work that way

Varen OP ,
@Varen@kbin.social avatar

@anamethatisnt
Thanks for helping out, kbin kind of doesn‘t have the option but the functionality 🤷🏻‍♂️

Varen OP ,
@Varen@kbin.social avatar

@orsetto
it's not a laptop, it's a desktop.
Yes, I did download the -nvidia versions, didn't do the trick and daily run it with acpi=off is no option since many things don't work anyways with that setting

Varen OP , (edited )
@Varen@kbin.social avatar

@rufus

thanks for taking the time. I already asked over at the asus-linux discord about the issue but got no reactions up until now.

Turn off Safe Boot and features that inhibit booting other operating systems and USB media in your BIOS.

did already, unfortunately not working

Get the installer running. Try the failsafe and fallback video mode options.

all installers (except nobara) do fail when trying to get the bootloader installed, since efibootmgr seems to be in need of the acpi options and I don't get it running with acpi option on.

Tackle one problem at a time. Google it. Add your hardware in question (“Asus Strix G15”) and error message or exact issue (“black screen”) to your query.

that's exactly what I'm trying to do, first and most important (from my understanding) would be to get the OS booted from the USB with acpi on. I am going through google/DDG/qwant/whatever-search-engine to look it up and tried everything I was able to find in relation to my Hardware, but wasn't able to tackle the issue up until now, that's why I'm asking for help all over the reddits/lemmys/kbins/discords...

I can get Nobara - and only Nobara - installed so I can boot without USB, but there as well only with acpi off.

I tried with Fedora, Nobara, ubuntu LTS, pop!_os, GarudaOS, silverblue, Mint, with everyone having the issue not being able to boot without acpi=off and getting to a black screen and USBs (seem) powered off right after choosing the OS in grub.

appreciate your time replying, thank you.

Varen OP ,
@Varen@kbin.social avatar

@rufus

I will try and report back if I can get the dmesg output. But since I guess that the USB gets cut off right before something happens I guess there simply isn‘t.

Will try with the installed Nobara and see, if dmesg catches anything up at all

Varen OP ,
@Varen@kbin.social avatar

@rufus

I‘m afraid that it‘s where it will fail, cause I can‘t get it to work with acpi on

I thought of getting the „bad installed“ (acpi=off) OS, let it start with acpi on and afterwards grab the logs again with acpi off, but don‘t know if that will work…

Varen OP ,
@Varen@kbin.social avatar

@lemmyreader

tried just right now. I get „booting a command list“ and nothing more, stays like that and USB Devices seem to be off.

Varen OP ,
@Varen@kbin.social avatar

@rufus
Alright, will try later and report back the outcome / pastebin if I can grab it

Varen OP ,
@Varen@kbin.social avatar

@lemmyreader
Thank you for the suggestion, I really do appreciate anyone who could have a clue what could go wrong and takes the time trying to help me out.

Yeah, Ventoy is the latest I had to burn the ISOs on the USB and stayed with it since :)

Varen OP ,
@Varen@kbin.social avatar

Yeah thank you, I really hope we‘ll get some progress.

(Not doing it on purpose, it‘s just how kbin behaves 😅 really thinking about dropping it and give lemmy a try. Originally decided for kbin because I wanted both worlds but since the behaviour is so strange …yeah 😉)

Varen OP ,
@Varen@kbin.social avatar

I tried so many parameter, that i can‘t remember anymore everyone ^^ but tried just now, unfortunately no change, same behavior

Varen OP ,
@Varen@kbin.social avatar

Will have look into it and try it out, but will need some time. Will defo reply back once tested 👍🏻 thank you!

Varen OP , (edited )
@Varen@kbin.social avatar

Unfortunately nothing. Did install - reboot with acpi=off, reboot with no acpi parameter, reboot with acpi=off

Dmesg shows for the boot=-1 the first boot after install with acpi=off

No log for the try without acpi parameter 😢😢

Booting with acpi=off shows many logs with „IRQ not found for nvidia …“ (in the meaning, not wordly).

Edit: can‘t find an irq for your nvidia card

Edit 2: found a boot.log file. When trying to boot without acpi=off then no log is written, the bootprocess doesn‘t even start. From this point of view I‘d guess a Problem with UEFI. Still no idea what and where, but it‘s not graphics related if the bootprocess doesn‘t start at all… what d‘you think?

Varen OP , (edited )
@Varen@kbin.social avatar

Yes, secure boot is set to Other OS - if set otherwise there’s a message after grub that secure boot is active, so pretty sure about that.

Unfortunately it doesn‘t show anything, even with no parameters at all. The only thing that shows up when changing the grub parameters is the „booting a command line“ message which stays there forever, nothing happens.
I‘ll record it with my phone when I get home later on today with the nomodeset parameter.

Varen OP ,
@Varen@kbin.social avatar

yeah ... as you can see in one of my other comments, I already joined the asus-linux discord and asked the "same" question (really, nearly with the exact same words...) and got , unfortunately, absolutely no reaction to it (besides on comment about "you need to disable the nouveau driver")...

Varen OP ,
@Varen@kbin.social avatar

Don‘t get me wrong, I‘m not complaining at all, in contrary, I am enormous grateful for any help I get.
I posted alread in reddit as well - subreddits r/Nobara, r/linux4noobs and r/linuxquestions
Asus-Linux has a thready-like area in their discord „general-issues“, where I made the thread…

At first it is to learn how everything behaves, test my use-cases to see, if linux could become an all-dayer for me - that would be the main goal - until then the dual-boot to have a fallback option.

Varen OP ,
@Varen@kbin.social avatar

appreciate it, thank you

Varen OP ,
@Varen@kbin.social avatar

yeah, already played around with VirtualBox and WSL, but there are use-cases (e.g. in gaming) where just an emulation can't really show what's possible and what not, that's why I would love to have the dualboot, so I can reliably test everything without any excuses like "runs probably bad because of emulation"

Varen OP ,
@Varen@kbin.social avatar

took the video
https://youtu.be/855QTzZlhWk
as you can see, absolutely nothing happens or shows up. (still uploading rn, should be available shortly)

Varen OP ,
@Varen@kbin.social avatar

yeah, that's the reason I am so desperate ... I understand, so maybe about time to look around for a new mobo?
anyways, I wanted to thank you very much for your time and effort in figuring out and trying to help me, I really do appreciate it very much!

Varen OP ,
@Varen@kbin.social avatar

No worries, at least you tried and I‘m grateful for it.

One last thing: so you would also go for mobo replacement? In my opinion its uefi/bios and a new mobo should help, but I like having more opinions…

Thank you again for trying

Varen OP ,
@Varen@kbin.social avatar

Wow thank you so much for keeping up on it!

I tried the earlyprintk options, but unfortunately none of them did work. Neither did the orher acpi options show up something, I do still have the exact same behaviour :(

I will work through the troubleshoot link you pasted, thank you as well for that.

Appreciate your help, I guess I‘ll start thinking about replacing the mobo

Varen OP ,
@Varen@kbin.social avatar

Yeah I already got one in mind and looked it up on linux-hardware.org - any other option I‘d have to make sure the next one is alright? (Besides socket and compatibility with my other hw)

Varen OP ,
@Varen@kbin.social avatar

Alright, no worries! You invested so much time and effort trying to help me out, I can‘t thank you enough for that, really really appreciate it much!

Varen OP ,
@Varen@kbin.social avatar

Oh I absolutely can relate haha
Maybe one day I‘ll be here asking dumb questions again, watch out 😁

Varen OP , (edited )
@Varen@kbin.social avatar

got some news. I don't think, that it might change something, but who knows.
I added in grub the option "insmod progress" (which I found by googling somewhere). It should show, if kernel and initrd do load or not and now I can see, that the vmlinuz and initrd are loading to 100% and after that it hangs. So it looks like the kernel loads but then stucks.
As said before, I don't think that this might change something in regards to further tests with my actual mobo, but I didn't want to left that out ...

Varen OP ,
@Varen@kbin.social avatar

ok took me 3 days to test, apologies :D
but unfortunately, no, doesn't work. Even the "old" iso stucks at the exact same position with the exact same behavior :(

  • All
  • Subscribed
  • Moderated
  • Favorites
  • random
  • All magazines